[MNL2] Unavailable credit card payments
Incident Report for mnl2
Resolved
CouldSigma would like to inform you that the credit card payment issue has been resolved.

Our 24/7 live support team is available for future assistance on the matter in case you are still experiencing any issues.

We apologize for any inconvenience caused.
Posted Aug 31, 2023 - 10:24 UTC
Investigating
CouldSigma would like to inform you of an ongoing issue with our payment processing.

Currently, we are having issues processing new credit card payments.

Please be advised that any existing account balance is unaffected and can be used for purchases and general consumption. In case you would like to add funds to your account balance you can use the Bank transfer top-up option.

Our 24/7 live support team is available for future assistance on the matter.

We will post an update as soon as we have any news or resolution to the payments issue.
Posted Aug 31, 2023 - 09:06 UTC
This incident affected: Manila 2 Cloud.